dhcp是什么意思 dhcp是什么意思开不开

导读:今天主要向大家介绍有关DHCP的内容,有需要的朋友可以收藏一下!

一、 DHCP概述

1、DHCP

Dynamic Host Configuration Protocol 动态主机配置协议,是一种提供传输配置信息到主机的方法。

客户机使用UDP68端口发送请求报文,服务器使用UDP67端口回应,给客户机提供ip地址以及其它相关信息,如网络掩码、路由、DNS服务器地址等。基于Client-Server模式,信息格式与BOOTP类似。

2

手工配置IP地址的优缺点

(1)缺点:

配置繁琐;

容易导致IP地址冲突;

可移动性较差;

安全性得不到保障。

干货|什么是DHCP?这些我们应该知道

(2)优点:

配置简单;

可移动性较好;

相对安全。

3、地址分配方式

自动分配— DHCP分配永久的IP地址给主机

动态分配— DHCP分配给客户机一个地址的租约(或直到主机声明放弃地址)

手动分配— 主机IP地址由管理员指定

注:仅仅动态分配有地址回收机制。

干货|什么是DHCP?这些我们应该知道

二、DHCP常见术语

DHCP client:DHCP 客户机,通过DHCP 获得网络参数的主机。

DHCP server:DHCP 服务器,为DHCP client提供网络参数的主机。

BOOTP relay agent:BOOTP 中继代理,在DHCP 服务器和DHCP 客户之间传送DHCP 消息的主机或路由器。

DHCP relay agent:DHCP 中继代理,在DHCP 服务器和DHCP 客户之间传送dhcp 消息的主机或路由器。

binding:绑定、封装。将收集的配置参数(至少包括一个ip地址),封装并分配给客户机。这个动作是由服务器处理的。

干货|什么是DHCP?这些我们应该知道

三、Dhcp server配置步骤

1. 启动/关闭DHCP服务器功能

2. 配置DHCP地址池

(1) 创建/删除DHCP地址池

(2) 配置动态DHCP地址池的参数

(3) 配置手工DHCP地址池的参数

3. 启动记录地址冲突的日志功能

4. 配置发ping包的个数和超时时间

Switch(Config)# service dhcp

Switch(Config)#ip dhcp pool A

Switch(dhcp-A-config)#network 10.16.1.0 24

Switch(dhcp-A-config)#lease 3

Switch(dhcp-A-config)#default-route 10.16.1.200 10.16.1.201

Switch(dhcp-A-config)#dns-server 10.16.1.202

Switch(dhcp-A-config)#netbios-name-server 10.16.1.209

Switch(dhcp-A-config)#exit

Switch(Config)#ip dhcp excluded-address 10.16.1.200 10.16.1.210

Switch(Config)#ip dhcp excluded-address 10.16.2.200 10.16.2.210

Switch(Config)#ip dhcp pool B

Switch(dhcp-A1config)#host 10.16.1.210

Switch(dhcp-A1-config)#hardware-address 0003.2223.dcab

Switch(Config)# ip dhcp conflict logging//*地址冲突缺省启用

Switch(Config)#ip dhcp ping timeout 1000 //*ping超时缺省500ms

Switch(Config)#ip dhcp ping packets 5//*缺省发ping包个数为2

干货|什么是DHCP?这些我们应该知道

四、Dhcp中继

在大型的网络中,可能会存在多个子网。DHCP客户机通过网络广播消息获得DHCP服务器的响应后得到IP地址。但广播消息是不能跨越子网的。因此,如果DHCP客户机和服务器在不同的子网内,客户机还能不能向服务器申请IP地址呢?

这就要用到DHCP中继代理。

DHCP中继代理实际上是一种软件技术,安装了DHCP中继代理的计算机称为DHCP中继代理服务器,它承担不同子网间的DHCP客户机和服务器的通信任务。

1DHCP 中继配置任务序列如下:

启动 DHCP 中继

配置 DHCP 中继转发 DHCP 广播报文

说明:网络中已存在DHCP Server,Vlan 20内PC的IP地址通过DHPC Relay方式获得。

组网图:

干货|什么是DHCP?这些我们应该知道

2、DHCP Server的配置

switch(config)#service dhcp 开启dhcp服务

switch(config)#ip dhcp pool vlan20 创建dhcp地址池

switch(dhcp-vlan20-config)#network 10.1.2.1 24 dhcp的地址范围

switch(dhcp-vlan20-config)#default-router 10.1.2.1 dhcp网关

switch(dhcp-vlan20-config)#exit

干货|什么是DHCP?这些我们应该知道

3、DHCP Relay的配置

switch(config)#service dhcp 开启dhcp服务

switch(config)#ip forward-protocol udp bootps 开启dhcp中继转发udp广播报文

switch(config)#vlan 10

switch(config-Vlan10)#ip address 10.1.1.2 255.255.255.0 配置IP地址switch(config-Vlan10)#exitswitch(config)#vlan 20

switch(config-Vlan20)#ip address 10.1.2.1 255.255.255.0 配置IP地址switch(config-Vlan20)#ip help-address 10.1.1.1 指定dhcp中继转发UDP报文的目的地址

switch(config-Vlan20)#exit

干货|什么是DHCP?这些我们应该知道

五、Dhcp Snooping

DHCP Snooping 功能指交换机监测 DHCP CLIENT 通过 DHCP 协议获取 IP 的过程。它通过设置信任端口和非信任端口,来防止 DHCP 攻击及私设 DHCP SERVER。

从信任端口接收的 DHCP 报文无需校验即可转发。典型的设置是将信任端口连接 DHCP SERVER 或者 DHCP RELAY 代理。非信任端口连接 DHCP CLIENT,交换机将转发从非信任端口接收的 DHCP 请求报文,不转发从非信任端口接收的 DHCP 回应报文。

如果从非信任端口接收DHCP 回应报文,除了发出告警信息外,并可根据设置对该端口执行相应的动作,比如shutdown、下发 blackhole。

如果启用了 DHCP Snooping 绑定功能,则交换机将会保存非信任端口下的 DHCP CLIENT 的绑定信息,每一条绑定信息包含该 DHCP CLIENT 的 MAC地址、 IP 地址、租期、 VLAN 号和端口号,这些绑定信息存放于 DHCP Snooping 的绑定表。

干货|什么是DHCP?这些我们应该知道

如上图:

1、Mac-AA 设备为正常用户,连接在交换机非信任端口 1/1 上,其通过 DHCP Client获得 IP 1.1.1.5;

2、DHCP Server 和 GateWay 分别连接在交换机的信任端口 1/11 ; 1/12 上;恶意用户 Mac-BB 连接在非信任端口 1/10 上,试图伪装 DHCP Server(发送 DHCPACK)。

3 、在交换机上设置 DHCP snooping 将能有效发现并阻止这种网络攻击。

干货|什么是DHCP?这些我们应该知道

交换机配置为:

switch#

switch#config

switch(config)#ip dhcp snooping enable 开启dhcp侦听功能

switch(config)#interface ethernet 1/11

switch(Config-Ethernet1/11 )#ip dhcp snooping trust 设置信任端口

switch(Config-Ethernet1/11 )#exit

switch(config)#interface ethernet 1/12

switch(Config-Ethernet1/12)#ip dhcp snooping trust 设置信任端口

switch(Config-Ethernet1/12)#exit

switch(config)#interface ethernet 1/1 -10

switch(Config-Port-Range)#ip dhcp snooping action shutdown 其余端口收到dhcp服务时直接阻塞端口

switch(Config-Port-Range)#

公众号:安徽思恒信息科技有限公司,了解更多技术内容……

【版权声明】叽叽歪歪吧提醒您:请在浏览本网站关于《dhcp是什么意思 dhcp是什么意思开不开》信息时,请您务必阅读并理解本声明。本站部分内容以及图片来源于商家投稿和网络转载,如网站发布的有关的信息侵犯到您的权益,请及时与我们取得联系,邮箱:20451 17252#qq。com,我们会尊重您的决定并当天作出删除处理。

(0)
上一篇 2022年5月8日 17:05:04
下一篇 2022年5月8日 17:25:04

相关推荐

  • 萤火虫在发光的同时也在发热吗 萤火虫不发光了怎么办

    萤火虫在发光的同时也在发热吗(萤火虫不发光了怎么办)蚂蚁庄园小课堂9月21日今日支付宝答案!相信很多玩家都不知道这个答案,答对就可以领取到180g小鸡饲料。以上是支付宝蚂蚁庄园小课堂2020年9月21日的题目,那么你们知道答案是什么吗?蚂蚁

    2022年5月8日 生活小知识
    1
  • 儿童洗衣机哪个好 中国洗衣机十大名牌

    儿童洗衣机哪个好(中国洗衣机十大名牌)随着9月开学季的到来,家长终于能摆脱熊孩子在家疯狂的“折磨”了。然而在疫情反复的当下,如何在孩子开学期间做好健康防护、避免细菌交叉感染,成为了家长另一头等大事。对于家长来说,孩子除了佩戴口罩、勤洗手外,

    2022年4月11日 生活小知识
    0
  • 问卷调查报告范文 问卷调查开展情况报告

    问卷调查报告范文(问卷调查开展情况报告)调查问卷的分析报告写法基本是相同的,重点是要对调查报告的结构特点要熟悉,对调查报告的写作程序要掌握。(一)结构调查报告通常包括标题、导语、资料统计、概况介绍、分析内容、总结。1.标题部分。调查报告分单

    2022年3月20日
    9
  • 女大学生如何创业(未来十年最紧缺生意)

    女大学生如何创业(未来十年最紧缺生意)根据去年年底对上海23所高校1075名在校生进行的“上海大学生创业现状调查”报告,约75%的在校生对创业充满期待。 近年来,为了支持大学生创业,各级政府出台了许多优惠政策,但社会大众对大学生创业的看法差

    2022年2月8日 生活小知识
    15
  • 地震捐款倡议书(为村捐款倡议书)

    地震捐款倡议书(为村捐款倡议书)7月17日以来,河南省遭遇大范围极端暴雨,多地降水量打破历史记录,强降水造成郑州、洛阳、平顶山、安阳、鹤壁、焦作、三门峡、南阳、信阳、周口、驻马店和济源示范区等所辖31个县区140个乡镇28万余人受灾,农作物

    2022年2月27日 生活小知识
    8
  • 上海塞舌尔公司注册 注册塞舌尔公司名称基金

    上海塞舌尔公司注册(注册塞舌尔公司名称基金)企业选择在海外注册离岸公司的目的,无外乎为了上市和合理避税考虑。而塞舌尔作为国际重要的离岸金融中心之一,拥有各大离岸金融中心的共同优势,也是全球最受欢迎的离岸公司注册地之一,吸引了全球客商在此注册

    2022年3月21日
    16
  • 输入对方手机号码直接定位 对方关机怎样定位找到对方

    输入对方手机号码直接定位(对方关机怎样定位找到对方)关机了,只能确定最后开机位置,通过110平台联系电信服务公司(移动联通电信),确认最后网络位置和之前网络轨迹,能大概预估关机位置。

    2022年4月16日
    1
  • 中央广播电视塔(中央电视台塔好看吗)

    中央广播电视塔(中央电视台塔好看吗)中央电视塔灯光秀春节期间华丽开启,带您看看不一样的中央电视台。伴随着新年脚步的临近,央视春晚也在紧锣密鼓的彩排当中,根据歪歌传媒小伙伴现场爆料,目前“三彩”已经结束,更多的明星大腕也浮出水面。为了喜迎牛年

    2022年3月5日 生活小知识
    20
  • 居民和非居民的区别(居民与非居民的区别举例说明)

    居民和非居民的区别(居民与非居民的区别举例说明)“居民”、“非居民”的税收身份您清楚吗?“无住所个人”跟“非居民个人”又是什么关系?今天,申税小微就来和您好好聊一聊!01 身份判定1.居民个人:在中国境内有住所,或者无住所而一个纳税年度内在

    2022年3月3日 生活小知识
    16
  • 机动车登记证书编号是什么 车辆过户登记证书编号是啥

    机动车登记证书编号是什么(车辆过户登记证书编号是啥)刚买了辆二手车要选号,交管12123平台轻松办理,足不出户就可办理预选号。温馨提示:市民可以先通过页面的号段公布字样,点击进入可查看近期投放的号段,新车预选号和二手车预选号号段一致。二手车

    2022年4月10日 生活小知识
    0

发表评论

登录后才能评论